AutoComplete

- **AutoComplete**: If the first few letters you type in a cell match an entry you've already made in that column, Excel will fill in the remaining characters for you. Just press ENTER when you see them added.

- This works for text or for text with numbers. It does not work for numbers only, for dates, or for times.
Editing a Cell

• **Double-click a cell** to edit the data in it.
• Click the cell, and then edit the data in the **formula bar**.
• The worksheet now says **Edit** in the status bar.
• To save the changes in the cell, press ENTER or TAB.
• If you are editing and made a mistake, you can press **ESC**. The changes will not take place.
Sometimes a cell displays ###### even when you know entered data in it.

This means that the cell is not wide enough to display the number (or date).

Double-click the right column boundary at the top to make more room. Also you can drag the right column boundary as in the example.
Cell Formats

- Every cell can have several formats in Excel.
- The most common are:
  - General (no format)
  - Numbers (1, 394, 22.3)
  - Currency ($2.43)
  - Text
  - Percentage (33.4%)
Changing the Cell Format

• Right click on a cell then select the **Format Cell** option.

• The menu allows you to change the formatting of any selected cell.
Changing the Cell Format (2)

• You can also change the format by using the Numbers panel of the Home tab (it will show a preview of what the cell will look like in that format.)
Removing Cell Format

• If you want to remove all cell formatting that you added (cell format, text size, text font, text color, etc) on a cell, select it and use the Clear Formatting button in the Editing panel of the Home tab.
Cell Alignment

• Just like tables in Word, we can align the data in each cell:
  – **Horizontal alignment**: left, right, centered, justified.
  – **Vertical alignment**: top, middle, bottom.

• The buttons are the same as in Word (**Home** panel).
Changing the Font

• You can change the font type, size, color, etc, using the **same method** as with **Word** or **PowerPoint**.
Inserting Images

• We can also insert images in an Excel workbook just as we did with Word, PowerPoint using the Picture button of the Insert tab.
Inserting Rows

• Sometimes you need another row to hold additional information.
• Click any cell in the row immediately below where you want the new row to appear.
• Then in the **Home** tab, click the **Insert** button of the **Cells** panel.
• Then click **Insert Sheet Rows**.
Inserting Rows (2)

• Before inserting the row:

• After inserting the row:
Inserting Columns

• Click any cell in the column immediately to the right of where you want the new column to appear.
• Then in the **Home** tab, click the Insert Button of the Cells panel.
• Then click **Insert Sheet Columns**
Inserting Columns (2)

• Before inserting the column:

![Before inserting the column diagram]

• After inserting the column:

![After inserting the column diagram]
Cell Borders

- You might want to eventually print your worksheet.
- If you don’t put any **cell borders**, all you will see is the content of the cells (numbers, text, etc).

Worksheet content in Excel

What it will look like when printed.
Adding Cell Borders

• You can add many different types of cell borders by clicking the **Borders** button in the **Home** tab.
• Simply click on the cell or cells that you wish to add a border to, then apply any border type.
Printed Example With Borders

- If we print the same example as before after adding borders we would get the following.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Column A</td>
<td>Column B</td>
<td>Column C</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Worksheet content in Excel (with borders)

What it will look like when printed.
Border Types

- Bottom Border
- Top Border
- Left Border
- Right Border
- No Border
- All Borders
- Outside Borders
- Thick Box Border
- Bottom Double Border

- Thick Bottom Border
- Top and Bottom Border
- Top and Thick Bottom Border
- Top and Double Bottom Border

- Draw Borders
  - Draw Border
  - Draw Border Grid
  - Erase Border
  - Line Color
  - Line Style
  - More Borders...
Sorting Values

• A very useful feature in Excel is the **Sort & Filter** button of the **Home** tab.

• This button allows you to sort different types of data in **ascending** (increasing) or **descending** (decreasing) order.
Sorting Numbers

• Let’s say you have a column of numbers that you need to have sorted (ex: Student IDs).

• **Step 1: Select all the values** you want to be part of the sort

• **Step 2**: Click the **Sort & Filter** button, then click the **order** you want to numbers to be sorted in (increasing or decreasing).

• **Step 3**: Your numbers should now be **sorted** in the order you selected!
Sorting Numbers Example

**Step 1:** Selecting the values to be sorted.

**Step 2:** Clicking the Sort & Filter Button

**Step 3:** Values are now sorted!
Sorting Text

- **Text** can also be sorted *lexicographically* (a<b, b<c, c<d, etc). Use the same steps used to sort numbers.

**Step 1:** Selecting the values to be sorted.

**Step 2:** Clicking the Sort & Filter Button

**Step 3:** Values are now sorted?
Oops! The Data is Not ALL Sorted!

• If we look back at our text example, we notice that Mary is not where it should be (should be before Robert).

• What happened?
Oops! The Data is Not ALL Sorted!

• **Explanation:** by default, Excel expects you to be using **headers** for your columns. So it **ignores** the first element of the list you selected (in our case Mary).

• To **force** Excel in also sorting the first element of the column, we’ll have to go in the **Custom Sort** option of the **Sort & Filter** button.
Custom Sort Menu

- We can create our own type of sorting using this menu, but for now the option that we are concerned about is the “My data has headers” option.
Custom Sort Menu

- Un-checking the “**My data has headers**” item will force Excel to sort all the elements of our column. If we have a header we are better to leave this option checked however.
- If we un-check the option and do our sort again, every is sorted as we expect it to be.
Chapter 8B

INTRODUCTION TO MICROSOFT EXCEL PART 2
Basics of Excel

• Last lecture we saw some of the basic components of Excel:
  – rows
  – columns
  – cells
  – toolbars
  – etc...
In Part 2 We’ll See...

• Some more cell **formatting**
  – adding colors, etc.

• **Formulas**
  – one of the most important part of Excel

• Using **cell references**

• **Special functions**
Cell Formatting

Fill colors, cell styles, merging and splitting cells.
Cell Formatting

• We talked about cell formats last lecture (number, text, date, etc).

• Here we’ll talk about the formatting a cell to change how it looks (color, font, etc).

• We’ll see how to use:
  – Fill color
  – Cell styles

• We’ll also see how to merge and split cells.
Fill Color

- Sometimes you want to highlight a cell so it **stands out** in a spreadsheet.
- The simplest way to do this is using a **Fill Color** for that cell.
- To apply a fill color, select a cell or cells then click the **Fill Color** button of the **Home** tab.
Fill Color (2)

- After selecting the color, your cell or cells will be filled with that **new color**.
- You might want to change the color of the text in that cell to make it **more visible**.
Cell Styles

• Similar to the **Styles** in Word, Excel includes different font styles that you can apply on cells.
• In the **Home** tab, click on the **Cell Styles** button of the **Styles panel**.
Cell Styles (2)
Applying Styles

• To apply a style simply select the cell or cells then click on the style you want to apply.
Merging and Splitting Cells

• We’ve seen in HTML and Word that it is sometimes useful to merge cells together (make a cell span multiple rows/columns).

• Merging and splitting cells can be done with the **Merge and Center** button.
Merging Cells

• To merge two or more cells together, select the cells then click **Merge and Center** or **Merge Cells** (the difference is that Merge and Center also centers the content of the cell.)
Merging Cells (2)

- Cells from different rows or columns can be merged as one, but they must be **adjacent** cells.
Merging Cells (3)

- If more than one cell has data before merging, only the data from the *upper-left-most cell* will be kept.
Splitting Cells

• After cells have been merged you can split the merged cell back to the original cells using the **Unmerge Cells** button.
Merge Across

• The **Merge Across** option will merge the columns of one or multiple rows together.
Note on Merged Cell

• When merging a bunch of cells together, what would be the reference of that merged cell?
• I mentioned last lecture that if you merge several cell with data already in those cells, only the data in the top-left-most cell is kept.
• The new cell will also inherit the cell reference of the top-left-most cell before merging:
Formulas

Basics, operators, pre-defined functions, special functions.
Formulas

• You can use Excel as a calculator by typing **simple formulas** into cells.

• Formulas are entries that have an **equation** that calculates the value to display.

• Instead of typing numbers, we type in the equation.

• The value of the equation will be **updated** automatically upon the **change** or **entry** of any data that is **referenced** in the equation.
Basic Math Operators

- **Add** operator : +
  
  Ex: $5 + 2$

- **Subtract** operator : −
  
  Ex: $5 - 2$

- **Multiplication** operator : *
  
  Ex: $5 \times 2$

- **Division** operator : /
  
  $5/2$
Simple Formulas

• To add a formula in Excel, click on a cell and start by typing the equal sign “=“.
• For example you can type in: = 5 + 2 and press the Enter key.
• The cell will display the result of the formula, instead of the formula.
• You can still see the formula by clicking on a cell and looking in the Formula bar.
Functions

- Pre-defined formulas in Excel are called **functions**.
- We’ll see many types of functions available such as **Sum**, **Average**, etc.
- **Formulas** are typed in by the user, functions are already defined and can be part of **formulas**.
AutoSum

• Excel has many pre-built functions that are used very often.
• Adding all the values of a column or row is a very common operation, so it has its own button called **AutoSum** in the **Formulas** tab.
Adding the Contents of a Column

- Suppose you have a **column** that contains your expenses for every month of the year and you want to **add** up all your expenses for that year.
- Select all the numbers you want to be part of the sum then click the **AutoSum** button.
Adding the Contents of a Column (2)

• After clicking the **AutoSum** button, a new cell appears below the selected data with the **sum of every element selected**.
Other Functions

- In addition to the **Sum** function, there are several other common functions that you can add just as easily by clicking a button. The **Formulas** tab contains buttons for different **categories** of functions.
Financial Functions

- Contains **financial** functions you would need to calculate:
  - Mortgage payments
  - Loan payments
  - Interest
  - etc...
Logical Functions

• Contains logical operators such as:
  – AND
  – TRUE
  – FALSE
  – IF: conditional statement (we’ll see more about this one).
  – etc...
Text Functions

• **Text-related** functions such as:
  – FIND: find text in a cell
  – LEN: length of text in a cell (how many characters).
  – REPLACE
  – etc...
Date and Time Functions

- Functions used to format or compare dates and times.
  - YEAR
  - MONTH
  - MINUTE
  - DAY
Cell References

• Before we can start and write our own formulas we need to review **cell references**.

• We’ve seen previously that a cell reference is the **column** and **row** for that cell (ex: B3, C11, Z43).

• There are **other types** of references used to represent more than one cell.

• Let’s look at a few examples to see the different types of cell references we have in Excel.
Cell References (2)

- **C1** is the cell in column C, row 1.
- **C4, B2** is a reference to two different cells, C4 and B2.
- **B2:B4** is a reference to a block of elements from B2 to B4 (B2, B3, B4) which in this case is a column.
- **B2:C4** is a reference to a block of data spanning columns B and C, and rows 2 to 4 (see figure).
Cell References (3)

- Cell references **identify** individual cells in a worksheet.
- Used in the formulas as **arguments**
- Excel can automatically **update the results** of formulas that use cell references, if you change the **content** of that cells.
- Excel can automatically **update the reference** of the cells (arguments) when you **copy** a formula to another cell.
References Between Worksheets

• We’ve seen how a workbook (an Excel file) can have multiple worksheets.
• It is often useful to be able to reference a cell from one worksheet in another worksheet.
• Sheet2!C14 for example would reference the cell C14 in worksheet Sheet2.
• There are ways to reference a cell in another workbook, but that is beyond the scope of this class.
Creating a Formula

• Now that we’ve seen an example of a simple formula (=2 + 5) and cell references, we are ready to write our own formulas using references.

• Let’s take a simple example of a budget that we have in Excel. We want to calculate the sum of our expenses for every month.
Creating a Formula (2)

• We’ve seen how to use the AutoSum button, but here we want to type in our own formula that will use the **SUM** function instead.

• We’ll start by writing a formula to add all the expenses for the month of **January**.

• Click in the cell below the values in the January column (in the cell B7).
Creating a Formula (3)

• Type in the “=“ character to begin entering a formula.
• Since we want to do the sum of the numbers, we’ll start by typing in the **SUM** function.
• As soon as you start typing a formula, Excel will try and guess what function you want to enter (typing “S” will list all functions that start with “S”).
Creating a Formula (4)

• After typing in “=SUM”, open a bracket “(“.
• Excel is now expecting a range of numbers to add them up.
• You can add the range in different ways:
  – use your mouse to select the numbers you want to sum.
  – enter the cell references by typing them in (in our case B2:B6).
Creating a Formula (5)

• After you’ve finished selecting or entering the cells you wish to add simply press the Enter key (that will accept the formula).

• The cell containing the formula now displays the sum of all the expenses for the month of January.
Why Use Formulas?

• Why go through all those steps to add those numbers when we could have added them up using a calculator an then entered the total in cell B7?

• The reason of course is that a formula will always be correct even if you make changes to the values used for the sum.

• If you typed in 1195.00 in cell B7, then changed your Rent amount from 700 to 710, cell B7 would still display 1195.00 even if the correct result should now be 1205.00.
Why Use Formulas?

• Even after changing values in the column of data, the sum formula displays the **correct sum**.

<table>
<thead>
<tr>
<th></th>
<th>January</th>
<th>February</th>
<th>March</th>
<th>April</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rent</td>
<td>710.00</td>
<td>700.00</td>
<td>710.00</td>
<td>710.00</td>
</tr>
<tr>
<td>Bus Pass</td>
<td>60.00</td>
<td>60.00</td>
<td>60.00</td>
<td>60.00</td>
</tr>
<tr>
<td>Bills</td>
<td>150.00</td>
<td>150.00</td>
<td>160.00</td>
<td>160.00</td>
</tr>
<tr>
<td>Food</td>
<td>200.00</td>
<td>192.00</td>
<td>180.00</td>
<td>205.00</td>
</tr>
<tr>
<td>Other</td>
<td>85.00</td>
<td>93.00</td>
<td>71.00</td>
<td>97.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>1205.00</td>
</tr>
</tbody>
</table>

*1/19/2015 COMP1001A - Chapter 8: Introduction to Microsoft Excel 67*
Insert Function

• If you don’t know the name of the function you want to use in your formula you can use the Insert Function button in the Formula tab.
• It will open a menu that will let you find and insert the correct formula.
Copying Formulas

• Suppose we want to also do the sum of the other months in our budget file (February, March, etc...).
• We could repeat all of our steps, but there is a simpler way.
• Excel allows us to copy formulas from cell to another.
• The copying is also smart enough to change the references so it will add the data in the new column or row.
Copying Formulas (2)

• If we take our example again, we already wrote our formula for the month of January in the B7 cell.

• Select the B7 cell and click **copy**, then select the C7 cell and select **paste** (you can use the copy/paste buttons of the home tab, or keyboard shortcuts, or right-click with the mouse.)
Copying Formulas (3)

• If you click on cell **C7** you will notice that the references have been **automatically updated** so that the formula sums the values in **column C** now.
Copying Formulas (4)

• There is another way to copy formulas that is very useful when you are copying a formula to multiple columns or rows.

• Remember the Fill Handle we discussed last lecture, we can use this feature to copy the formula to as many contiguous cells that we need.

• We’ll use this method to copy the formula from column C to columns D and E.
Copying Formulas (4)

• Click on the cell containing the formula you want to copy.
• Click and drag the fill handle and stop in the last cell you want this formula to be copied in.
Copying Formulas (5)

• Using this method the formulas are also **automatically updated** so they add the elements of the proper column.

<table>
<thead>
<tr>
<th></th>
<th>January</th>
<th>February</th>
<th>March</th>
<th>April</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A</strong></td>
<td><strong>B</strong></td>
<td><strong>C</strong></td>
<td><strong>D</strong></td>
<td><strong>E</strong></td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Rent</td>
<td>710.00</td>
<td>700.00</td>
<td>710.00</td>
</tr>
<tr>
<td>3</td>
<td>Bus Pass</td>
<td>60.00</td>
<td>60.00</td>
<td>60.00</td>
</tr>
<tr>
<td>4</td>
<td>Bills</td>
<td>150.00</td>
<td>150.00</td>
<td>160.00</td>
</tr>
<tr>
<td>5</td>
<td>Food</td>
<td>200.00</td>
<td>192.00</td>
<td>180.00</td>
</tr>
<tr>
<td>6</td>
<td>Other</td>
<td>85.00</td>
<td>93.00</td>
<td>71.00</td>
</tr>
<tr>
<td>7</td>
<td></td>
<td>1205.00</td>
<td>1195.00</td>
<td>1181.00</td>
</tr>
</tbody>
</table>
Another Formula Example

• Let us try another formula using another function.
• We’ll calculate the **average** cost of our food expense over the months of January-April.
• We’ll add the formula to the right of the data in the row (cell **F5**). We start by entering the “=“ character.
Another Formula Example (2)

• Now we want the average function. If we don’t know the name of a function we can use the Insert Function button, it will open a menu and asks to enter a description of the function you are looking for.
• We can enter “average” and Excel will return the best matches for that function, which is the AVERAGE function.
• After we insert the AVERAGE function, it will open another menu asking what values we want to use as arguments for the AVERAGE function.
Another Formula Example (3)

![Insert Function dialog box showing the selection and explanation of the AVERAGE function.]

AVERAGE(number1, number2, ...)

Returns the average (arithmetic mean) of its arguments, which can be numbers or names, arrays, or references that contain numbers.
Another Formula Example (4)

Function Arguments

AVERAGE

Number1: 35;ES = \{200, 192, 180, 205}\)

Number2 = number

= 194.25

Returns the average (arithmetic mean) of its arguments, which can be numbers or names, arrays, or references that contain numbers.

Number1: number1,number2,... are 1 to 255 numeric arguments for which you want the average.

Formula result = 194.25

Help on this function
Another Formula Example (5)

• The values we are interested in are from B5 to E5 or B5:E5. Once we enter those values in the AVERAGE function, it returns the average of all the values from B5 to E5 in cell F5.
Another Formula Example (6)

• If we already knew the name of the function we wanted to use, we could have simply typed in the function name and the cells to use as arguments in the Formula bar.
Useful Functions

- **SUM**: Calculates and displays the sum of the values in the argument.
- **MIN**: Calculates and displays the minimum value within the argument.
- **MAX**: Calculates and display the minimum value within the argument.
- **AVERAGE**: Calculates and displays the average of the values in the argument.
Using Dates in Formulas

• Once a cell has been formatted using the Date type, Excel will recognize that cell as a date and will be able to do operations using dates.

• Examples
  – How many days are there between March 9th 2009 and April 3rd 2009?
  – 50 days from March 9th 2009 will fall on what day of the week?
Using Dates in Formulas (2)

• There are 25 days between March 9th 2009 and April 3rd 2009.

• 50 days from March 9th 2009 will fall on a Tuesday.
Formula Errors

• When there is errors in the formulas, Excel display some special text.

• #REF!
  – A cell reference is not valid. Cells may have been deleted or pasted over.

• #NAME?
  – You may have misspelled a function name or used a name that Excel does not recognize.

• #DIV/0!
  – The formula is trying to divide by 0.
Formula Errors (2)

- **#NAME?**
  - Formula: =CD3d
  - Description: Cell D contains the error #NAME? because the cell name 'CD3d' is not defined or visible in the Excel sheet.

- **#DIV/0!**
  - Formula: =0/0
  - Description: Cell D contains the error #DIV/0! because it attempts to divide zero by zero, which is undefined in mathematics.

- **#REF!**
  - Formula: =#REF!
  - Description: Cell D contains the error #REF! because the referenced cell is not defined or is not visible in the Excel sheet.
Special Functions

Conditional Statements (IF), Logical operators (AND, OR, NOT).
The IF Function

• Checks if a condition is true, and return one value if TRUE and another if FALSE.
• The IF statement answers the question, “Is this true or false?”
• Then proceeds takes an action based on the answer.
• The if statements has 3 arguments:
  – **Logical test**: what we are testing
  – **Value if true**: what we want to displayed if the answer to our question is “true”
  – **Value if false**: what we want to display if the answer is “false”
Age Example

• As an example imagine if we have rows of names and each name has an age in the next column.
• According to the age, determine if the person is over or under 21.
• We want the function to display “OVER” if the person is over or is 21 (≥21), and “UNDER” otherwise (<21).
Age Example (2)

• We need three arguments for our IF function
  – the test (CELL>=21, greater or equal to 21), where CELL is the cell we want to test (B1, B2, B3…).
  – value if true (“OVER”, in quotes since it is text).
  – value if false (“UNDER”, also in quotes).

• We write our formula using the IF function and those arguments. We’ll write it in the first row, then we’ll copy the formula to the other rows.

![Excel formula example]

=IF(B1>=21,"OVER","UNDER")
Age Example (3)

• Once we are finished entering our formula we press the Enter key and see the result.
• John is over 21, which is correct since he is 32.
Age Example (4)

• Click and drag the **Fill Handle** of cell C1 to the other cells of column C. This will **copy** our formula to all the other cells in this column.
Conditional Formatting

• Now that we have seen what is a conditional statement (IF function) we can finally see **conditional formatting**.

• Conditional formatting will format a cell depending on the value it contains.

• For example, you want cells that contain **negative** values to have a **red background**, and those containing **positive** values to have a **green background** (which might be useful in a budget, red = bad!).
Conditional Formatting (2)

• Click on the cells you want to apply your conditional formatting.

• Click on the **Conditional Formatting** button in the **Home** tab.

• You have many possible options from text highlighting, icons, color scales, etc.
Highlight Cell Rules

- Highlight a cell IF:
  - greater than
  - less than
  - between
  - equal to
  - etc...
Top/Bottom Rules

• Highlights:
  – top 10 items
  – top 10%
  – bottom 10 items
  – bottom 10%
  – etc…
Data Bars

• Using data bars the cells will display colored bars.
• The higher the value, the longer the bars
Icon Sets

• Displays different icons in the cell depending on the value.
Other Rules

• You can create your own rules by clicking the **Conditional Formatting** button then **New Rule**.
Conditional Formatting Examples
Creating a Conditional Formatting Rule

• Suppose we want to create a simple conditional formatting rule:
  – If a cell contains a value below 0, change the cell fill color to blue.
  – If a cell contains a value above or equal to 0, change the cell fill color to red.
Creating a Conditional Formatting Rule (2)

- Select the values you want to apply the conditional formatting to, click the Conditional Formatting button, then click New Rule.
Creating a Conditional Formatting Rule (3)

• Here we want to use the “Format only cells that contain” option.
• Then we can set to only apply the format if the value in the cell is **less than 0**, and choose the **format** we want.
Creating a Conditional Formatting Rule (4)

- The rule we applied in the previous step will change the fill color of every cell with values less than 0 as blue.
- We then need to add another rule for values 0 and over to have a red fill color.
Creating a Conditional Formatting Rule (5)

• Follow the same steps as those we used to add the first rule, except now we’ll have a different condition.
• If the cell value is greater or equal to 0, then change the fill color to red.
Creating a Conditional Formatting Rule (5)

• The result of the two rules can be seen here, we have the effect that we were looking for.
Editing the Conditional Formatting Rules

- We can **view** (or **edit**, **remove**, **add**) the rules applied to one or more cells by selecting them, clicking on **Conditional Formatting** button, then selecting **Manage Rules**.
Logical and Other Operators

AND, OR, NOT, <=, >=, etc...
Logical Operators

• **Logic** is a very important part of Mathematics and Computer Science.

• We won’t go in details on logic but just see the basics so you know how to use logical operators.

• Logic is used to decide when a sentence composed of other sentences is **TRUE** or **FALSE**.

• We call TRUE or FALSE **truth values**.

• **Example**: It is raining **AND** it is windy.
Logical Operators (2)

• We’ll see the following (most important) logical operators and how they are used:
  – AND
  – OR
  – NOT
The AND Operator

• The **AND** operator can be used to evaluate if two statements are true at the same time.

• In other words, for two statements $A$ and $B$, $\text{AND}(A, B)$ will ONLY be **TRUE** if $A$ is **TRUE** and $B$ is **TRUE** (otherwise it will be **FALSE**).
The AND Operator Examples

• **Example 1:** suppose cell B2 contains the value 20. Will \( \text{AND}(B2>10, B2<30) \) be true or false?
  
  **Answer:** \( B2>10 \) is TRUE, \( B2<30 \) is also TRUE, therefore the answer of \( \text{AND}(B2>10, B2<30) \) will be TRUE.

• **Example 2:** Suppose cell C2 contains the value 40. Will \( \text{AND}(C2>10, C2<30) \) be true or false?
  
  **Answer:** \( C2>10 \) is TRUE, but \( C2<30 \) is FALSE. Therefore \( \text{AND}(C2>10, C2<30) \) is FALSE.
The AND Operator Answer Table

Here’s a table to help you figure out the answer of the **AND** operator for two different values:

<table>
<thead>
<tr>
<th>AND</th>
<th>TRUE</th>
<th>FALSE</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>TRUE</td>
<td>FALSE</td>
</tr>
<tr>
<td>FALSE</td>
<td>FALSE</td>
<td>FALSE</td>
</tr>
</tbody>
</table>
The OR Operator

• The **OR** operator can be used to evaluate if either one of two statements are true, or both.

• In other words, for two statements \( A \) and \( B \), \( \text{OR}(A, B) \) will be **TRUE** if \( A \) is **TRUE** or if \( B \) is **TRUE**, or if both are true. It will only be false when **both** \( A \) and \( B \) are **FALSE**.
The OR Operator Examples

Example 1: Suppose cell C2 contains the value 40. Will \textbf{OR}(C2>10, C2<30) be true or false?

\textbf{Answer:} C2>10 is TRUE, but C2<30 is FALSE. But since at least one of them is TRUE, \textbf{OR} (C2>10, C2<30) is also \textbf{TRUE}.
The OR Operator Answer Table

- Here’s a table to help you figure out the answer of the **OR** operator for two different values:

<table>
<thead>
<tr>
<th>OR</th>
<th>TRUE</th>
<th>FALSE</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>TRUE</td>
<td>TRUE</td>
</tr>
<tr>
<td>FALSE</td>
<td>TRUE</td>
<td>FALSE</td>
</tr>
</tbody>
</table>
The NOT Operator

• The NOT operator will change any truth value to its opposite.

• \textbf{NOT(TRUE)} equals \textbf{FALSE}.

• \textbf{NOT(FALSE)} equals \textbf{TRUE}. 
Logical Operator Use in Excel

• Logical operators will help us write formulas that will test for certain conditions.

• For example, let’s say we are writing an Excel sheet for a class. Every row will contain a student ID, the mark for the midterm and the mark for the final.

• We want to have another column that will say “PASS” if the student had over 55 on the midterm AND over 55 on the final, and “FAIL” otherwise.
Logical Operator Use in Excel (2)

• We’ve seen everything we need to solve this already: **IF function** and **AND operator**.

• In English we could write this as:
  IF that student had over 55 for the midterm and over 55 for the final, then that student gets a “PASS”, otherwise that student gets a “FAIL”.

• We need to rewrite this using Excel function IF and operator AND.
Logical Operator Use in Excel (3)

Answer: `IF(AND(B2>55, C2>55), “PASS”, “FAIL”)`

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>Student ID</td>
<td>Midterm</td>
<td>Final</td>
<td>=IF(AND(B2&gt;55, C2&gt;55), &quot;PASS&quot;, &quot;FAIL&quot;)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10012345</td>
<td>90</td>
<td>54</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10012346</td>
<td>80</td>
<td>85</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10012349</td>
<td>52</td>
<td>100</td>
<td>FAIL</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10012350</td>
<td>55</td>
<td>55</td>
<td>FAIL</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10012355</td>
<td>60</td>
<td>65</td>
<td>PASS</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10012357</td>
<td>40</td>
<td>80</td>
<td>FAIL</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Other Comparison Operators

• Different: <>
• Equal: =
• Greater than: >
• Greater or equal then: >=
• Less than: <
• Less or equal than: <=
Charts

Bar charts, Pie charts,
Column graphs, etc.
Charts in Excel

• Excel has the tools to insert charts in spreadsheets.

• Charts can be efficient ways to present complex information such as tables.

• We’ll see many different types of charts:
  – Pie charts
  – Bar charts
  – Line charts, etc
Before Starting a Chart

• Know what you want to show and why
• Keep it simple and clear
• Target your audience
• Focus on the message
Suggestions for Charts

- Do not try to add every excel feature
- Avoid 3-D Charts
  - Distort the data
- Keep simple colors
  - Avoid colorful background
  - If the chart is going to be printed then try to use grayscale or Black/White
Inserting Charts

• We’ll see a few different ways to insert charts in Excel.

• One way is to use the **Chart buttons** in the **Insert** tab.
Types of Charts: Column

- **Column charts** can represent data using different vertical shapes:
  - Rectangles
  - Cylinders
  - Pyramids
  - etc
Types of Charts: Line

• **Line charts** are the most basic of charts.
• It can represent data points as lines in a graph.
Types of Charts: Pie

- **Pie charts** can be very useful to represent percentages of a total.
Types of Charts: Bar

• **Bar charts** are basically the same as column charts, except the bars are horizontal instead of vertical.
Types of Charts: Area and Scatter
Types of Charts: Other

- There are many other types of charts:
  - Stock
  - Surface
  - Doughnut
  - Bubble
  - Radar
Chart Components

- **Title**: Marks
- **Y-axis Label**: Mark (/100)
- **X-axis Label**: Student IDs
- **Legend**: Midterm, Final
- **Columns**
Creating a Chart

• The first thing you need before creating a chart is **data**!

• Let’s say I want to chart the results of the midterm and final exam from the example we saw earlier.

<table>
<thead>
<tr>
<th></th>
<th>Student ID</th>
<th>Midterm</th>
<th>Final</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>10012345</td>
<td>90</td>
<td>54</td>
<td>FAIL</td>
</tr>
<tr>
<td>2</td>
<td>10012346</td>
<td>80</td>
<td>85</td>
<td>PASS</td>
</tr>
<tr>
<td>3</td>
<td>10012349</td>
<td>52</td>
<td>100</td>
<td>FAIL</td>
</tr>
<tr>
<td>4</td>
<td>10012350</td>
<td>55</td>
<td>55</td>
<td>FAIL</td>
</tr>
<tr>
<td>5</td>
<td>10012355</td>
<td>60</td>
<td>65</td>
<td>PASS</td>
</tr>
<tr>
<td>6</td>
<td>10012357</td>
<td>40</td>
<td>80</td>
<td>FAIL</td>
</tr>
</tbody>
</table>
Step 1: Selecting the Data

• To create a chart we should first **select the data** we want to chart.

• We want to chart columns **B** and **C** of my example so we will select the proper cells.

![Excel Table]

- **A** - Student ID
- **B** - Midterm
- **C** - Final

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>10012345</td>
<td>90</td>
<td>54</td>
<td>FAIL</td>
</tr>
<tr>
<td>3</td>
<td>10012346</td>
<td>80</td>
<td>85</td>
<td>PASS</td>
</tr>
<tr>
<td>4</td>
<td>10012349</td>
<td>52</td>
<td>100</td>
<td>FAIL</td>
</tr>
<tr>
<td>5</td>
<td>10012350</td>
<td>55</td>
<td>55</td>
<td>FAIL</td>
</tr>
<tr>
<td>6</td>
<td>10012355</td>
<td>60</td>
<td>65</td>
<td>PASS</td>
</tr>
<tr>
<td>7</td>
<td>10012357</td>
<td>40</td>
<td>80</td>
<td>FAIL</td>
</tr>
</tbody>
</table>
Step 2: Select a Chart Type

- **Choose a char type** from all the different types we have seen.
- We’ll choose a **2-D Column chart**.
Inserted Chart

• The chart is now inserted, but still missing some information such as a title, etc.
Step 3A: Series Names

• First we want to change the series names (Series1, Series2) to **Midterm** and **Final**.

• Right click on the chart, then click **Select Data**.
Changing the Series Names

• Click on the **series name** you want to edit on the left, then click the **Edit button**.
Changing the Series Names (2)

- In the window that opens, enter the name you want under **Series Name**, then click OK. We have to do the same for the other Series (Final).
Changing the Series Names (3)

[Bar graph showing comparison between Midterm and Final scores for six categories]
Step 3B: Column Names

• Notice that by default every set of column is numbered (1, 2, 3...). We want to add the student IDs instead.
• Right click on the chart, then click Select Data again.
Changing the Column Names

• In the **Select Data** Source window, click on the **Edit** button of the **Horizontal (Category) Axis Labels**.

• We don’t need to type in the IDs again since they are in our worksheet already. Select the cells containing the IDs.
Changing the Column Names (2)
Step 3C: Adding a Title and Axis Labels

- By default the chart does not have a **title** or **axis labels**. To add them we need to change the **chart layout**.
- After double-clicking a chart, the **Design** Tab will appear.
- Click on the **Quick Layout** button and choose a layout that includes both a title and axis labels.
Step 3C: Adding a Title and Axis Labels (2)

- Click on the **Title** and **Axis** labels and type in text to change them.
Layout Tab

• We can also add the Title or Axis labels using the Layout Tab.
• The layout tab will become available when you select a chart.
Layout Tab: Chart Title

• You can add a title with the layout tab by clicking the Chart Title button.
Layout Tab: Legend

- Using the **Legend button** you can:
  - Turn legends on/off
  - Change the location of the legend
  - Change the overlay of the legend (on top of the chart, etc)
Layout Tab: Data Labels

- You can add or change the position of data labels with the **Data Labels** button.
Layout Tab: Axis and Gridlines

• In charts that contain axes you can change the axis values of the horizontal (x) and vertical (y) axis with the **Axes button**.

• In charts with gridlines you can change the horizontal and vertical gridlines.
  - add more gridlines
  - remove gridlines
  - etc.
Changing the Chart Type

• Even after you are finished with your chart, you can change the chart type.
• Right-click on the chart and select **Change Chart Type**.
Changing the Chart Type (2)
Moving a Chart

• You can move a chart in a spreadsheet simply by clicking and dragging it to its new position.
Resizing a Chart

• You can change the size of a chart by clicking it once, then **clicking and dragging the edges or corners** of the chart (like you would to resize an image).

• The font size of the text in the chart will stay the same, but the bars or columns will change size.
Updating the Content

- The data displayed by the chart comes from the worksheet as referenced cells.
- As cells are referenced, if you change a content in your table, the chart will change as well.
Pie Charts

• Pie charts can be very useful when you want to show how a whole is divided into shares.

• Example: what is the most used internet browser. What we want to show is that of all the users online, what percentages use Firefox, what percentage use Internet Explorer, etc...

• A pie chart would be much better suited for questions like this, we’ll see why.
Example: Browsers

![Bar chart showing browser usage]

- Mozilla Firefox: 45
- Internet Explorer: 40
- Google Chrome: 30
- Safari: 20
- Opera: 10
- Other: 5
Example: Browsers (2)
Line Charts

- **Line charts** are useful when you want to compare values across time.
- Let’s take our budget example from last lecture.
- We want to graph our **Other** expenses over those few months.

Table:

<table>
<thead>
<tr>
<th></th>
<th>January</th>
<th>February</th>
<th>March</th>
<th>April</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rent</td>
<td>700.00</td>
<td>700.00</td>
<td>710.00</td>
<td>710.00</td>
</tr>
<tr>
<td>Bus Pass</td>
<td>60.00</td>
<td>60.00</td>
<td>60.00</td>
<td>60.00</td>
</tr>
<tr>
<td>Bills</td>
<td>150.00</td>
<td>150.00</td>
<td>160.00</td>
<td>160.00</td>
</tr>
<tr>
<td>Food</td>
<td>200.00</td>
<td>192.00</td>
<td>180.00</td>
<td>205.00</td>
</tr>
<tr>
<td>Other</td>
<td>85.00</td>
<td>93.00</td>
<td>71.00</td>
<td>97.00</td>
</tr>
</tbody>
</table>
Line Chart Example: Budget

• We first select the data.

<table>
<thead>
<tr>
<th></th>
<th>Food</th>
<th>200.00</th>
<th>192.00</th>
<th>180.00</th>
<th>205.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Other</td>
<td>85.00</td>
<td>93.00</td>
<td>71.00</td>
<td>97.00</td>
</tr>
</tbody>
</table>

• Then click on the type of chart we want to insert (2-D Line Chart)
Line Chart Example: Budget (2)
Chart Styles

• Charts can have different styles in Excel.
• Double-click on a chart to open the Design tab.
• For every chart type there are many different styles you can apply.
Chart Styles (2)

- Each **chart style** will change how your chart looks (different colors, font, 3D effects, etc).
Chart Tips

• Make sure the **chart type** you are using represents well the data that you are presenting.
Chart Tips (2)

- Make sure the chart presents the data **clearly** and can be **understood** properly.
Compatibility Warning (again)

• Some functions of Excel 2007 are not compatible with earlier versions of Excel.
• For example some of the conditional formatting options were not present in earlier versions and might not work at all.
• When saving, Excel will give you a warning about any incompatible features you have used.
Compatibility Warning (again)

Microsoft Office Excel - Compatibility Checker

The following features in this workbook are not supported by earlier versions of Excel. These features may be lost or degraded when you save this workbook in an earlier file format. Click Continue to save the workbook anyway. To keep all of your features, click Cancel, and then save the file in one of the new file formats.

Summary

<table>
<thead>
<tr>
<th>Significant loss of functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>One or more cells in this workbook contain a conditional formatting type that is not supported in earlier versions of Excel, such as data bars, color scales, or icon sets. Location: 'Sheet1', Conditional Formatting</td>
</tr>
</tbody>
</table>

Number of occurrences: 1

Find Help

Check compatibility when saving this workbook.

Copy to New Sheet Continue Cancel
End of Our Excel Material

• So did we see *everything* about Excel?
• Of course not, there is still plenty of other functionality that we don’t have time to see.
• The best way to learn is to try, *experiment*!